Get in touch
Back
Resolved

System slowness

Started 22 Jun at 01:30pm PDT.

Lawmatics App - app.lawmatics.com
Created

app.lawmatics.com is currently experiencing system wide slowness. Our team is looking into this issue and an update will be posted when it is available.

Posted 22 Jun at 01:30pm PDT.